Gelöst Connektor hängt bei der Installation

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Nachdem ich aus Versehen alle Kategorien im Shopware Connektor gelöscht hatte, wollte ich diesen neu installieren. Leider hängt sich nun der Connektor bei der Installation im Backend von Shopware auf und hat nach ein oder zwei Stunden logisch einen Timeout.
In der Datenbank wird die Tabelle jtl_connector_category_level fleissig befüllt,
nicht jedoch die jtl_connector_category.
Nach dem timeout wird auch der Connector weiterhin nicht als installiert angezeigt.

Fehlermeldungen bekomme ich keine.
Jemand eine Idee?

Shopware Version 5.2.9
Connector: 2.07

 

Daniel B.

Moderator
Mitarbeiter
17. Juni 2009
1.430
39
Hey,

hast du die Kategorien im Shopsystem gelöscht oder wie muss ich das verstehen? Oder hast du die Mapping Tabellen nur geleert?

Lg,
Daniel
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Erst mal geleert, mit der Deinstallation des Connectors wurden sie dann aus der Datenbank entfernt (also nicht von Hand, ich hab nur nachgeschaut).
Bei der Neuinstallation wurden sie dann wieder angelegt und wie oben beschrieben, die jtl_connector_category_level befüllt.
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
800 Kategorien, 7000 Artikel, 500 Kunden, also sollte eigentlich nicht so dramatisch sein. Wohlgemerkt, es geht bloss um die Installation des Plugins im Shopware Backend, nicht um die Übertragung.
Es hat ja vorher auch schon funktioniert, anstandslos. Hat vielleicht 5 Minuten oder so gedauert. Der Server ist auch nicht ausgelastet, die Speichernutzung ist bei 15 %.
Das einzige was ich geändert habe, währenddessen, war einen Sprachshop hinzuzufügen, der im root unter Englisch liegt. Der Shop hat bei mir im Root drei Verzeichnisse. Es sind vier Subshops installiert und ein Sprachshop.
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Ich hab es zunächst mit dem 2.06 noch mal probiert, dann heute gesehn dass 2.07 draussen ist und den genommen.
Shop war zunächst 5.26, dann auf 5.28 geupdated.
Also ja.
Die JTL Wawi ist auf dem neuesten Stand, das hat aber ja nix mit dem Connector Plugin vom Shop zu tun, die Kommunikation wird seitens der Wawi ja erst hergestellt, wenn der Connector installiert & aktiviert ist und ich ein Passwort kriege.
Und um ganz sicher zu gehen habe ich das Plugin auch vollständig deinstalliert und kontrolliert, dass die Datenbanktabellen auch wirklich weg waren. Weiterhin auch die files im Pluginverzeichnis vollständig gelöscht.
Bin echt ratlos.
Zur Illustration, hier hängts, seit jetzt 4,5 Stunden:

Bildschirmfoto 2016-10-28 um 18.27.50.png Bildschirmfoto 2016-10-28 um 18.27.50.png
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Nein, das tat er ja eben auch nicht. Nach dem ich versehentlich die gemappten Kategorien via Abgleich gelöscht hatte, hat jeder Versuch mit 2.06 das Ganze wiederherzustellen auch nicht funktioniert.
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Jap hat es :D , bevor ich aus Versehen den Abgleich in Richtung Shopware gestartet hatte und damit die Kategorien, die ich in in der Datenbank gelöscht hatte eben auch aus dem Mapping rausgelöscht hatte.
Wollte eigentlich den Abgleich in die andere Richtung machen, weil beim Abgleich Shop --> Wawi so komische Artikelnummern rauskamen und hab eben noch mal die Wawi geleert.
Dann vergessen, den Connector zurückzusetzen und schwupps waren die gemappten Kategorien weg.
Interessanterweise auch nur die in den JTL Datenbanktabellen, die im Shop hinterlegten Kategorien waren ohne weiteres vorhanden und nicht gelöscht. Vielleicht ist das ja ein Hinweis darauf, dass es vorher auch nicht 100 % richtig funktioniert hat, da bin ich mir nicht ganz sicher.
Möglicherweise gibt es noch einen anderen Datenbankeintrag bezüglich des Connectors, der bei der De-Installation nicht gelöscht wird und jetzt für die Probleme sorgt, ich weiss es nicht. Ich wüsste aber auch grad nicht, wo anfangen mit dem Suchen....
 

Walde IT-Systeme

Gut bekanntes Mitglied
12. Mai 2015
132
2
Das ist eine nomaler Super Gau ... :cool:
Aber Backup ins JTL Wawi und Backup in den Shop ist scheinbar nicht mehr möglich ! Oder ?

Sind den die Daten auf einer der beiden Seiten noch in Ordnung ( ca. 100 % OK ? )
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Generell ist es undramatisch. Der Shop hängt momentan noch per Eci Connector an der Wawi. Will aber umsteigen auf den JTL Konnektor. Die bestehende Datenbank an den bestehenden Shop anbinden führt zu so vielen Problemen, dass ich es so versucht habe, den gefüllten Shop in eine jungfräuliche Wawi zu importieren. Also die Wawi ist leer, soll sie ja auch sein und der Shop ist voll und macht keine Probleme.
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Ich weiss auch nicht ob sich die Installationsroutine irgendwo aufgehängt hat, in der Datenbank ändert sich die Zahl der Datensätze der jtl_connector_category_level ständig, während die andere bei 0 bleibt.

Bildschirmfoto 2016-10-28 um 18.52.55.png Bildschirmfoto 2016-10-28 um 18.52.45.png
 

Walde IT-Systeme

Gut bekanntes Mitglied
12. Mai 2015
132
2
Kann mir das ja mal ansehen aber erst nach dem Wochenende falls du möchtest.
Melde dich einfach.
Muss jetzt los zum essen.
Wünsche noch was.
PS: Es könnte auch ein Problem im Hosting sein, hast du den Connector Test durchlaufen lassen ?
 

Annichaotica

Aktives Mitglied
30. September 2015
24
1
Strato, Managed Server. Dümmste Entscheidung ever! Kann nicht mal die IonCube Version updaten...
Sobald mein Vertrag ausläuft bin ich da weg, leider erst in 12 Monaten GRRR.
Ich versteh bloss nicht warum es vorher ging und jetzt nicht mehr.

Vielen Dank aufjedenfall, schönes Wochenende :D

Vielleicht hat der Daniel am Montag ja auch ne zündende Idee...
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
In Bearbeitung JTL-WAWI + FFN hängt beim Start und in Log JTL-Wawi - Fehler und Bugs 1
Neu Bei Auslieferung hängt sich der Hintergrundprozess auf. keine Rechnungen... JTL-Wawi - Fehler und Bugs 4
In Bearbeitung JTL Worker hängt etwa 1x täglich JTL-Wawi - Fehler und Bugs 12
In Bearbeitung Wawi hängt sich auf nach dem Login JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Fehlermeldung bei Markieren JTL-Wawi - Fehler und Bugs 1
Neu Shop 5 RC3 - kleiner Fehler bei "noindex" von Merkmalen JTL-Shop - Ideen, Lob und Kritik 0
Neu Fehler bei der Authentifizierung. Das Passwort in den Online Shop Einstellungen ist falsch. WooCommerce-Connector 0
Neu Rechnungsstellung bei Plattformen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Teillieferung bei Dropshipping-Aufträgen inkl. Versanddatenimport Arbeitsabläufe in JTL-Wawi 0
Neu Lagerbestand bei Stücklistenartikeln die in einer Vater/Kind-Variation zusammenhängen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Anzahl Artikel pro Seite bei Aufruf der Kategorie JTL-Shop - BETA - Feedback und Bugmeldungen 1
Neu Bondruck bei OPI JTL-POS - Fragen zu Hardware 3
Neu Rechnung bei EC-Karten Zahlung aus der Wawi Allgemeine Fragen zu JTL-POS 6
In Bearbeitung Fehler bei Layoutauswahl JTL-Wawi - Fehler und Bugs 2
Neu Extra knifflig: Wie Farbwechsel bei bestimmten Textstellen in einer Variable machen? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu unterschiedlicher EK bei Stücklisten bei Einzelbezug als bei Bezug vom Set der Stücklisten User helfen Usern - Fragen zu JTL-Wawi 3
Neu Versandkostenfrei bei mindestes Umsatz aus einer Kategorie User helfen Usern - Fragen zu JTL-Wawi 0
Neu Druckvorlagen - Wie den MWSt-Satz löschen (bei der Rechnungssummierung) Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Fehler bei Mahnlauf JTL-Wawi - Fehler und Bugs 1
Neu Positionshinweis bei Retouren aus Auftrag oder Ist Auftragsposition retouniert? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehlerhafte Zahleneingabe z.B. bei Barentnahme JTL-POS - Fehler und Bugs 4
Neu Worker zeigt oft Fehler bei Ebay Abgleich 1.5.31.0 User helfen Usern - Fragen zu JTL-Wawi 7
Neu Aufgerundeter MwSt.-Satz bei Rechnungen mit Händlerrabatt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Auftragsnummer bei jeder einzelnen Positon auf Rechnung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Zahlungsarten fehlen bei Firefox (und Edge) JTL-Shop - Fehler und Bugs 2
Gelöst Fehler bei Beendigung Objektname "Timer" nicht gefunden Gelöste Themen in diesem Bereich 2
In Bearbeitung B2B Preis senden kann bei FBA-Artikel nicht verwendet werden - keine Kaufmöglichkeit für Amazon-Businesskunden? Amazon-Anbindung - Ideen, Lob und Kritik 5
Neu Vorlage - Kreuz bei Umsatzsteuer über Massenänderung User helfen Usern - Fragen zu JTL-Wawi 1
In Bearbeitung Bei uns ist folgende Abholadresse hinterlegt ... Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Chaos bei Lager und Lieferanten Shopware-Connector 2
Neu Artikel bei aktivierter Bestandsführung im Shop vorbestellen Allgemeine Fragen zu JTL-Shop 3
Neu Shopware 5 auf 6 Updaten bei laufender Anbindung Shopware-Connector 0
Offen Automatisches Ausliefern per Workflow bei Versand über Fulfillment-Dienstleister JTL-Workflows - Ideen, Lob und Kritik 0
Neu Brauche Hilfe bei Formel für Lageretikett Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu "Zoom / Vergrößerung" bei Bildern deaktkvieren Allgemeine Fragen zu JTL-Shop 0
Neu Falscher Preis bei Konfigurationsgruppen-Artikel User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Falsche MHD/Charge auf Lieferschein bei Warenausgang über JTL-Packtisch+ [WAWI-50270] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 13
In Bearbeitung ebay-Bilder Massenänderung bei für mehrere Plattformen User helfen Usern - Fragen zu JTL-Wawi 6
Neu Versanddaten mit Fehler bei Umlagerungen erneut exportieren User helfen Usern - Fragen zu JTL-Wawi 1
Neu Anmeldung bei kundencenter.jtl-software.de regelmäßig erforderlich trotz StandAlone Version Einrichtung / Updates von JTL-POS 3
Verwiesen an Servicepartner Charset in Datei Schreiben bei Workflows JTL-Workflows - Fehler und Bugs 1
Neu Kann man bei Warenpost Sendungsreferenz mit ausgeben? JTL-ShippingLabels - Ideen, Lob und Kritik 1
Gelöst Wawi versendet Zahlungsbestätigung bei selbst angelegten Aufträgen, obwohl nicht gewünscht. Gelöste Themen in diesem Bereich 6
Gelöst Fehler bei Cond(Page() == 1, 110, 10) Gelöste Themen in diesem Bereich 3
Neu Bei PayPal Zahlungen wird falsch gerundet z.B. -0,01 Zahlung offen JTL-Shop - BETA - Feedback und Bugmeldungen 11
In Bearbeitung UVPs Massenupdate bei Amazon mit Selbsterstellten Produktseiten Amazon-Anbindung - Ideen, Lob und Kritik 3
Gelöst Das Feld "F.Zusatz" fehlt bei den Kundendaten/Rechnungsadresse in der Rechnungsmaske JTL-Wawi - Fehler und Bugs 3
Neu Achtung vor Update bitte bei PHP die Intl Version prüfen, sonst keine Kunden Registrierung möglich JTL-Shop - BETA - Feedback und Bugmeldungen 8
Neu Skontozahlung bei Übernahme aus Shop ohne MwSt Modified eCommerce-Connector 0
Neu Vorlagen Variable - Vater Artikelnummer ausgeben bei Variations-Artikeln im Lieferschein User helfen Usern - Fragen zu JTL-Wawi 0
Ähnliche Themen