In Bearbeitung Bon-Datum springt auf 01.01.1970

Unithekle

Neues Mitglied
12. August 2021
8
1
Hallo,

wir arbeiten mit JTL-POS (1.04.17) in Verbindung mit der WAWI (1.0.51.0).
Vergangenes Wochenende kam es nun bereits zum zweiten Mal vor, dass bei der Buchung eines Bons über JTL-POS plötzlich als Datum des Belegs der 01.01.1970 angegeben wurde. Er ist dann in der WAWI nicht mehr unter den neuesten Bons zu finden, sondern nur wenn man ihn explizit 1970 sucht. Außerdem springt die fortlaufende Bon-Nummer dann plötzlich zurück auf #0001 und fängt dann wieder von vorne an zu zählen.
Hat sonst noch jemand das Problem? Wie kann man den Fehler vermeiden/beheben?
Gibt es die Möglichkeit den Bon nachträglich auf das richtige Datum zu ändern?

Vielen Dank vorab und beste Grüße
Dieter
 

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
421
83
Hallo Dieter,

prüfe hierzu am besten einmal die Zeitzone und die Zeit- und Datumseinstellungen auf deinem Kassengerät. Aus irgendeinem Grund kann die Kasse nicht auf das aktuelle oder irgendein bestimmtes Datum zugreifen, weswegen hier der 01.01.1970 (Default-Wert) gesetzt wird. Genau dieses Datum, weil am ersten Januar 1970 die Unixzeit und damit die Zeitrechnung der Computer beginnt.

Gruß Stefan
 

Unithekle

Neues Mitglied
12. August 2021
8
1
Hallo Stefan,

vielen Dank für die hilfreiche Antwort.
Wir benutzen das Sunmi T2 als Kasse. Dort war bisher in den Android-Einstellungen eingestellt "Datum und Uhrzeit aus Netzwerk beziehen". Ich stelle jetzt mal auf "Manuelles Datum und Uhrzeit". Vielleicht hat die Kasse ja beim Kassiervorgang irgendwie das Netz verloren und deshalb das falsche Datum angegeben.
Muss in JTL-POS selbst noch was eingestellt werden? Dort habe ich nichts gefunden.
Kann das Datum des Bons im Nachhinein korrigiert werden (über WAWI)?

Grüße
Dieter
 

Stefan_F

Moderator
Mitarbeiter
21. Juli 2017
421
83
Hallo Dieter,

theoretisch ist es der sicherste Weg das Datum und die Uhrzeit aus dem Netzwerk zu beziehen. Eventuell gab es aber in deinem Fall das Problem, dass darauf nicht zugegriffen werden konnte oder eine abweichende Netzwerkzeit in deinem Netzwerk gespeichert war. Ich hoffe, es funktioniert jetzt wieder.

Den Bon kann man leider nachträglich nicht umdatieren. Die Bons müssen unveränderlich sein. Du kannst höchstens den betroffenen Bon retournieren und dann mit dem aktuellen Datum neu kassieren.

Gruß Stefan
 

Unithekle

Neues Mitglied
12. August 2021
8
1
Hallo Stefan,

vielen Dank für Deine Antwort. Das mit der Uhrzeit aus dem Netzwerk habe ich mittlerweile auch herausgefunden und es wieder umgestellt.
Schade, dass es keinen saubereren Weg gibt, als den Bon zu retournieren. Sieht nicht sonderlich schön aus, tut aber seinen Zweck. Habe es jetzt so gemacht und weiß zukünftig, wo ich suchen muss, wenn Bons fehlen.

Vielen Dank für Eure Hilfe
Dieter
 
  • Gefällt mir
Reaktionen: Stefan_F
Ähnliche Themen
Titel Forum Antworten Datum
Neu Kasse druckt Bon + Lieferschein, Lieferschein soll nicht an dem Bondrucker ausgegeben werden User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Kasse hängt bei Bon erstellen JTL-POS - Fehler und Bugs 1
Neu Bondrucker schneidet zu früh den BON ab Fragen rund um LS-POS 2
In Bearbeitung JTL-POShat Bon erstellt, kommt aber nicht im Kassenbuch vor JTL-POS - Fehler und Bugs 2
Neu Vorschlag: Digitaler Bon - Anzeigedauer QR-Code JTL-POS - Ideen, Lob und Kritik 0
In Diskussion Logo für Bon in JTL-POS auf Chromebox JTL-POS - Fragen zu Hardware 10
In Bearbeitung Seit heute kein Drucken von Bon möglich JTL-POS - Fehler und Bugs 17
In Bearbeitung Bondrucker TM30 druckt Bon nur halb JTL-POS - Fragen zu Hardware 3
Neu Redundanter Bon - Tagesabschluss falsch Allgemeine Fragen zu JTL-POS 2
Neu Anbindung Amazon - Bestellungen ab einem bestimmten Datum übernehmen Amazon-Anbindung - Ideen, Lob und Kritik 2
Neu X:\Lieferscheine\{{ Date.Now }}_{{ Report.OperationId }}.pdf - Datum funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 1
Neu Nach Rechnungskorrektur ist Rechnung "Bezahlt am..."-Datum = Ursprungsauftrags-Datum - Warum? JTL-Wawi - Fehler und Bugs 0
Neu Wawi 1.6.32.0 Nach Bearbeitung eines Auftrags springt der Tab nicht mehr in die Wawi JTL-Wawi - Fehler und Bugs 1
Neu Nach Update auf 5.1 Springt die Startseite wenn der Cookiebanner noch nicht angeklickt wurde JTL-Shop - Fehler und Bugs 3

Ähnliche Themen