Beantwortet Bestandswarnung funktioniert nur im Test

HEYHO!

Mitglied
23. April 2020
21
0
Hallo liebe JTL Community,

ich habe einen Workflow angelegt, welcher eine E-Mail an unseren Produktionsleiter versendet, wenn die verfügbare Bestand eines Produktes geringer ist als der Mindestbestand des Artikels (=2). Ich glaube den Grund dafür muss ich hier nicht näher ausführen. Wenn ich den Workflow teste, funktioniert dieser einwandfrei und der Test der Bedingung sowie die Ausführung erfolgen immer korrekt. An diesem Punkt hört die Funktionalität jedoch auch auf, da der Workflow nie ausgelöst wird, wenn durch den Verkauf von Produkten der verfügbare Bestand unterhalb des Mindestbestandes fällt.

Ich bin ein wenig mit meinem Anfänger-Latein am Ende und wollte euch daher mal fragen, ob jemanden eine Lösung dafür in den Sinn kommt. Ich habe euch ein Foto des Workflows anschließend mit angehangen.

Screenshot (24)_LI.jpg
Falls noch weitere Informationen zur Lösung benötigt werden, schreibt doch gerne in die Diskussion.

Vielen Dank für die Mühe im Voraus
Linus von HEYHO!
 

Simone_die_Echte

Sehr aktives Mitglied
10. April 2014
1.095
268
Ordne den WF mal unter dem Punkt "Warenlagerausgang" -> "Minusbuchung" ein.
Ich bin auch nicht so wirklich fit im Thema Workflow, aber ich denke, dass es dort klappen sollte.
Der verfügbare Bestand sinkt doch unter 2 wenn ein entsprechender Warenausgang stattfindet.
 

jtldudel

Sehr aktives Mitglied
4. Januar 2018
296
92
Ordne den WF mal unter dem Punkt "Warenlagerausgang" -> "Minusbuchung" ein.
Ich bin auch nicht so wirklich fit im Thema Workflow, aber ich denke, dass es dort klappen sollte.
Der verfügbare Bestand sinkt doch unter 2 wenn ein entsprechender Warenausgang stattfindet.
Grundsätzlich gute Idee, das Problem ist nur das eine Auslieferung hier auch nicht als Minusbuchung erkannt wird. Der Workflow müsste im Grunde nach jeder Auslieferung die Artikel prüfen die ausgeliefert wurden, z.B. unter "Auftrag Ausgeliefert". Das Thema wurde meine ich hier schon öfter mal diskutiert und nie so richtig mit einem befriedigenden Ende.

Am Ende ist es einfach wenn man Täglich in die Bestellvorschläge geht und sich die Artikel anzeigen lässt die unter dem Mindestbestand gefallen sind.

@Linus mal kurz erklärt, da Links steht in der Maske das auslösende Ereignis. Dein Workflow steht unter "Artikel erstellt", wird also NUR starten für einen Artikel der gerade erst erstellt wurde. Deshalb löst der hier praktisch nie aus.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.713
1.169
Es bedarf zwei Workflows, um alles abzudecken.
Unter Minusbuchung UND unter Auftrag ausgeliefert.
Hintergrund ist, dass nunmal das die Auslöser für die jeweiligen Workflows sind.
Eine Minusbuchung ist kein Ausgelieferter Auftrag und umgekehrt. Und ein erstellter Artikel - nun ja - der wird nur ein mal erstellt und danach nie wieder. Insofern kann so ein Workflow auch nur ein einziges mal pro Artikel ausgelöst werden.
 

Simone_die_Echte

Sehr aktives Mitglied
10. April 2014
1.095
268
Wenn die Auslieferung über die Wawi stattfindet bedarf es wohl der Lösung von Enrico.

Bei Auslieferung über den Packtisch+ müsste jedoch mein Ansatz reichen.
Ich habe einen WF mit der Bedingung "Warenauslagerung\Artikel\Allgemein\Lager\Bestandsübersicht\Auf_Lager" Kleiner gleich 6
Nach der Auslieferung über den Packtisch erhalte ich eine entsprechende Mail wenn der Bestand unter 6 gerutscht ist.
 

HEYHO!

Mitglied
23. April 2020
21
0
Hello an alle,

komme gerade erst wieder aus dem Urlaub zurück und wollte mich eben für die reichliche Hilfe bedanken. Ich versuche es nun noch einmal mit dem Input von Enrico und werde mich melden, sollte es so für uns funktionieren.

Vielen Dank und eine erfolgreiche Woche an alle!
Die HEYHO Haferbande
 

HEYHO!

Mitglied
23. April 2020
21
0
Ganz kurz nochmal als Rückmeldung:

Also zunächst kann ich sagen, dass es mit Enrico's Vorschlag schon mal funktioniert, dennoch ist daraus ein weiteres Problem entstanden, da es unter dem Punkt "Aufträge" für die Aktion nicht die Variable Artikelname gibt und jetzt bekommen wir zwar Bestandswarnungen, jedoch ohne uns sagen zu können, um welchen Artikel es sich handelt. Wenn uns jemand sagen könnte, wie man das richtig einstellt, wäre uns wirklich sehr geholfen.

Vielen Dank
Eure HEYHO Haferbande
 

Verkäuferlein

Sehr aktives Mitglied
29. April 2012
1.273
374
Ganz kurz nochmal als Rückmeldung:

Also zunächst kann ich sagen, dass es mit Enrico's Vorschlag schon mal funktioniert, dennoch ist daraus ein weiteres Problem entstanden, da es unter dem Punkt "Aufträge" für die Aktion nicht die Variable Artikelname gibt und jetzt bekommen wir zwar Bestandswarnungen, jedoch ohne uns sagen zu können, um welchen Artikel es sich handelt. Wenn uns jemand sagen könnte, wie man das richtig einstellt, wäre uns wirklich sehr geholfen.

Vielen Dank
Eure HEYHO Haferbande

Wie sehen denn Deine Workflows aktuell aus, dass es soweit funktioniert und Du an den richtigen Bestand kommst?

Ich vermute, dass die Auftragspositionen per Schleife durchlaufen werden müssen, um dann an den richtigen Namen zu kommen.
 

und-aus

Aktives Mitglied
5. April 2019
39
4
bei uns läuft genauso ein Workflow!
Wenn Bestand gleich 6, dann email an lieferanten mit Preisanfrage zu diesem Artikel.

Bei mir ist der Workflow unter >>Artikel >> Geändert einsortiert.
 

jtldudel

Sehr aktives Mitglied
4. Januar 2018
296
92
D.h. eine Bestandsänderung durch ausliefern löst einen Workflow unter Artikel Geändert aus? Interessant, wusste ich gar nicht. Das würde ja das Problem lösen!
 

Verkäuferlein

Sehr aktives Mitglied
29. April 2012
1.273
374
D.h. eine Bestandsänderung durch ausliefern löst einen Workflow unter Artikel Geändert aus? Interessant, wusste ich gar nicht. Das würde ja das Problem lösen!

Hm, das würde ich jetzt bezweifeln. Als ich das mal getestet habe, ging es nicht. Vermutlich wird der Workflow anderweitig getriggert. Z. B. durch einen täglichen Bestandsdaten-Import des Lieferanten oder ähnliches.

Das würde mich auch interessieren. Könnte das jemand bitte nochmal beantworten?

Danke!

Kannst Du doch ggf. selber einmal ausprobieren, wenn Du einen entsprechenden Workflow hast.

Meines Erachtens müssen erst diese Tickets hier angegangen werden, damit es wirklich sauber funktioniert:
https://issues.jtl-software.de/issues/WAWI-10099
https://issues.jtl-software.de/issues/WAWI-51411
https://issues.jtl-software.de/issues/WAWI-24438
 

grosskranfan

Mitglied
18. Mai 2022
38
6
Es bedarf zwei Workflows, um alles abzudecken.
Unter Minusbuchung UND unter Auftrag ausgeliefert.
Hintergrund ist, dass nunmal das die Auslöser für die jeweiligen Workflows sind.
Eine Minusbuchung ist kein Ausgelieferter Auftrag und umgekehrt. Und ein erstellter Artikel - nun ja - der wird nur ein mal erstellt und danach nie wieder. Insofern kann so ein Workflow auch nur ein einziges mal pro Artikel ausgelöst werden.
Vielleicht denke ich zu naiv, aber was ist mit "Artikel->Geändert"?
 
Ähnliche Themen
Titel Forum Antworten Datum
Seit Update von 1.5.5.0 auf 1.6.39.0 funktioniert der Worker nicht mehr JTL-Wawi 1.6 1
Neu Wawi 1.6.38.2: Erweiterte Suche in der Artikelverwaltung - "Artikel" funktioniert nicht mehr JTL-Wawi - Fehler und Bugs 1
Testaufträge mit Rechnung löschen funktioniert nicht trotz Rechnungskorrektur JTL-Wawi 1.6 1
Neu SalesOrderPosition.ConfiguratorPositionParentId funktioniert nicht JTL-Wawi - Fehler und Bugs 1
OnPage Composer funktioniert nicht: "Firefox darf diese eingebettete Seite nicht öffnen" Einrichtung JTL-Shop5 1
Neu Auftragsdruck funktioniert nicht JTL-Wawi - Fehler und Bugs 0
Neu Cookie Plugin funktioniert nicht mehr, Postfach voll von Hinweisen Plugins für JTL-Shop 4
Neu Parcel One Positionen zusammenfassen funktioniert nicht JTL-ShippingLabels - Fehler und Bugs 0
Neu 1.6.xx Workflow testen funktioniert nicht. JTL-Wawi - Fehler und Bugs 0
Neu Prestashop Shopabgleich funktioniert nicht mehr PrestaShop-Connector 0
Neu JTL Wawi 1.6.38.2 - "Vorschläge für Umlagerungen in ein FBA Lager generieren" funktioniert nicht JTL-Wawi - Fehler und Bugs 0
Neu Ausgabe Mailen bei Aufträgen und Rechnungen funktioniert nicht JTL-Wawi - Fehler und Bugs 0
Neu JTL WaWi 1.6.38.2 - Menüleiste oben funktioniert nicht mehr - kann den Mahnlauf nicht starten ... JTL-Wawi - Fehler und Bugs 7
Neu Filtern nach "ß" funktioniert nicht JTL-Ameise - Fehler und Bugs 2
JTL SHOP 5 E-MAIL (gmail) FUNKTIONIERT EINFACH NICHT User helfen Usern - Fragen zu JTL-Wawi 4
In Bearbeitung Bondruck funktioniert nicht immer JTL-POS - Fehler und Bugs 3
JTLConnector: Abgleich Kunde funktioniert nicht JTL-Wawi 1.6 0
Workflow Rechnungen speichern funktioniert nicht mehr JTL-Wawi 1.6 2
Neu Funktionsattribut cms_page.name für Artikel funktioniert nicht Shopware-Connector 3
Neu 1.6.38.1 Zahlungsabgleich Import funktioniert nicht mehr JTL-Wawi - Fehler und Bugs 11
Gelöst Nach Updates funktioniert Datenabgleich WaWi/POS nicht mehr Einrichtung / Updates von JTL-POS 3
Neu Lieferzeitanzeige Versandart DHL funktioniert nicht Betrieb / Pflege von JTL-Shop 1
Neu Komplettabgleich funktioniert nur teilweise Einrichtung JTL-Shop5 0
Neu Wann funktioniert der Shopware6 Connector? Shopware-Connector 8
Neu Paypal Checkout funktioniert nicht - Paypal Zahlungsart nicht mehr vorhanden Plugins für JTL-Shop 5
Neu Sortierung der Artikel nach Erscheinungsdatum funktioniert nicht korrekt Allgemeine Fragen zu JTL-Shop 3
In Bearbeitung E-Mail Versand funktioniert nicht mehr. JTL-POS - Fehler und Bugs 1
Neu Amazon Abgleich funktioniert nicht Amazon-Anbindung - Fehler und Bugs 5
Beantwortet Auftrag erstellt - Abfrage ob Eigenes Feld nicht leer funktioniert nicht JTL-Workflows - Fehler und Bugs 7
Neu JTL Wawi empfangene Aufträge enthalten nur Vaternamen Shopware-Connector 1
Rechnungsvorlagen/ Fußzeile nur noch zur hälfte da. JTL-Wawi 1.6 1
Nach Update (Stunden später) keine Unterseiten mehr aufrufbar - nur Startseite Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Pickliste > Ausliefern erstellt wieder Pickliste statt nur auszuliefern JTL-Wawi - Fehler und Bugs 0
Neu "Das Handle ist ungültig" - Labeldruck nur über GKP möglich, Sendungsnummer aber in Wawi JTL-ShippingLabels - Fehler und Bugs 0
Artikelabhängigen Versand mit Artikelunabhängigen nur einmal mit dem teureren berechnen JTL-Wawi 1.6 0
Neu Farbcodierung bei ausgelieferten Aufträgen nur über Workflow JTL-Wawi - Fehler und Bugs 0
Neu Ameisen Import nur für bestimmten Shop JTL-Wawi 1.6 2
Neu Shopware Artikel nur in der jeweiligen Kategorie anzeigen - ohne Unterkategorien Shopware-Connector 0
Rechnungen haben keine Netto Positionen nur Brutto?! JTL-Wawi 1.6 2
Eigene Felder nur im Auftrag? JTL-Wawi 1.6 3
Neu Artikel nur innerhalb Deutschlands versenden Arbeitsabläufe in JTL-Wawi 2
Neu Artikel | Attribute/Merkmale | Merkmale lassen sich nur noch einzeln entfernen JTL-Wawi 1.6 1
Issue angelegt Retouren > nur angemeldete anzeigen im WMS [WAWI-62644, WAWI-62645] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Bei Zahlungsarten werden nur Vorkasse und Kreditkarte gezeigt JTL-Shop - Fehler und Bugs 1
Neu Mollie-Backend im 5er Shop lässt sich nur schwer aufrufen Plugins für JTL-Shop 1
Neu Element nur drucken wenn Seitenzahl > 1 ist Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu DATEV Anbindung nur direkt an den Steuerberater? Arbeitsabläufe in JTL-Wawi 0
Neu nur lieferschein errstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Exportvorlage - nur bestimmte Artikel im Feed - Fehlersuche Allgemeine Fragen zu JTL-Shop 5
Neu Komponenten-Namen nur auf deutsch im Auftrag, englischer Name wird nicht angezeigt JTL-Wawi - Fehler und Bugs 1

Ähnliche Themen