Beantwortet Bestandswarnung funktioniert nur im Test

  • Fehler bei Bestellberichten im Amazon Seller-Central

    Soeben ging ein Newsletter an alle User heraus mit wichtigen Informationen zu diesem Fehler und dessen Beseitigung.

    Wir haben hier die Informationen noch einmal hinterlegt: Klick

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

HEYHO!

Mitglied
23. April 2020
21
0
Hallo liebe JTL Community,

ich habe einen Workflow angelegt, welcher eine E-Mail an unseren Produktionsleiter versendet, wenn die verfügbare Bestand eines Produktes geringer ist als der Mindestbestand des Artikels (=2). Ich glaube den Grund dafür muss ich hier nicht näher ausführen. Wenn ich den Workflow teste, funktioniert dieser einwandfrei und der Test der Bedingung sowie die Ausführung erfolgen immer korrekt. An diesem Punkt hört die Funktionalität jedoch auch auf, da der Workflow nie ausgelöst wird, wenn durch den Verkauf von Produkten der verfügbare Bestand unterhalb des Mindestbestandes fällt.

Ich bin ein wenig mit meinem Anfänger-Latein am Ende und wollte euch daher mal fragen, ob jemanden eine Lösung dafür in den Sinn kommt. Ich habe euch ein Foto des Workflows anschließend mit angehangen.

Screenshot (24)_LI.jpg
Falls noch weitere Informationen zur Lösung benötigt werden, schreibt doch gerne in die Diskussion.

Vielen Dank für die Mühe im Voraus
Linus von HEYHO!
 

Simone_die_Echte

Sehr aktives Mitglied
10. April 2014
1.075
249
Ordne den WF mal unter dem Punkt "Warenlagerausgang" -> "Minusbuchung" ein.
Ich bin auch nicht so wirklich fit im Thema Workflow, aber ich denke, dass es dort klappen sollte.
Der verfügbare Bestand sinkt doch unter 2 wenn ein entsprechender Warenausgang stattfindet.
 

jtldudel

Sehr aktives Mitglied
4. Januar 2018
268
83
Ordne den WF mal unter dem Punkt "Warenlagerausgang" -> "Minusbuchung" ein.
Ich bin auch nicht so wirklich fit im Thema Workflow, aber ich denke, dass es dort klappen sollte.
Der verfügbare Bestand sinkt doch unter 2 wenn ein entsprechender Warenausgang stattfindet.
Grundsätzlich gute Idee, das Problem ist nur das eine Auslieferung hier auch nicht als Minusbuchung erkannt wird. Der Workflow müsste im Grunde nach jeder Auslieferung die Artikel prüfen die ausgeliefert wurden, z.B. unter "Auftrag Ausgeliefert". Das Thema wurde meine ich hier schon öfter mal diskutiert und nie so richtig mit einem befriedigenden Ende.

Am Ende ist es einfach wenn man Täglich in die Bestellvorschläge geht und sich die Artikel anzeigen lässt die unter dem Mindestbestand gefallen sind.

@Linus mal kurz erklärt, da Links steht in der Maske das auslösende Ereignis. Dein Workflow steht unter "Artikel erstellt", wird also NUR starten für einen Artikel der gerade erst erstellt wurde. Deshalb löst der hier praktisch nie aus.
 

Enrico W.

Administrator
Mitarbeiter
27. November 2014
6.632
1.141
Es bedarf zwei Workflows, um alles abzudecken.
Unter Minusbuchung UND unter Auftrag ausgeliefert.
Hintergrund ist, dass nunmal das die Auslöser für die jeweiligen Workflows sind.
Eine Minusbuchung ist kein Ausgelieferter Auftrag und umgekehrt. Und ein erstellter Artikel - nun ja - der wird nur ein mal erstellt und danach nie wieder. Insofern kann so ein Workflow auch nur ein einziges mal pro Artikel ausgelöst werden.
 

Simone_die_Echte

Sehr aktives Mitglied
10. April 2014
1.075
249
Wenn die Auslieferung über die Wawi stattfindet bedarf es wohl der Lösung von Enrico.

Bei Auslieferung über den Packtisch+ müsste jedoch mein Ansatz reichen.
Ich habe einen WF mit der Bedingung "Warenauslagerung\Artikel\Allgemein\Lager\Bestandsübersicht\Auf_Lager" Kleiner gleich 6
Nach der Auslieferung über den Packtisch erhalte ich eine entsprechende Mail wenn der Bestand unter 6 gerutscht ist.
 

HEYHO!

Mitglied
23. April 2020
21
0
Hello an alle,

komme gerade erst wieder aus dem Urlaub zurück und wollte mich eben für die reichliche Hilfe bedanken. Ich versuche es nun noch einmal mit dem Input von Enrico und werde mich melden, sollte es so für uns funktionieren.

Vielen Dank und eine erfolgreiche Woche an alle!
Die HEYHO Haferbande
 

HEYHO!

Mitglied
23. April 2020
21
0
Ganz kurz nochmal als Rückmeldung:

Also zunächst kann ich sagen, dass es mit Enrico's Vorschlag schon mal funktioniert, dennoch ist daraus ein weiteres Problem entstanden, da es unter dem Punkt "Aufträge" für die Aktion nicht die Variable Artikelname gibt und jetzt bekommen wir zwar Bestandswarnungen, jedoch ohne uns sagen zu können, um welchen Artikel es sich handelt. Wenn uns jemand sagen könnte, wie man das richtig einstellt, wäre uns wirklich sehr geholfen.

Vielen Dank
Eure HEYHO Haferbande
 

Verkäuferlein

Sehr aktives Mitglied
29. April 2012
1.159
316
Ganz kurz nochmal als Rückmeldung:

Also zunächst kann ich sagen, dass es mit Enrico's Vorschlag schon mal funktioniert, dennoch ist daraus ein weiteres Problem entstanden, da es unter dem Punkt "Aufträge" für die Aktion nicht die Variable Artikelname gibt und jetzt bekommen wir zwar Bestandswarnungen, jedoch ohne uns sagen zu können, um welchen Artikel es sich handelt. Wenn uns jemand sagen könnte, wie man das richtig einstellt, wäre uns wirklich sehr geholfen.

Vielen Dank
Eure HEYHO Haferbande

Wie sehen denn Deine Workflows aktuell aus, dass es soweit funktioniert und Du an den richtigen Bestand kommst?

Ich vermute, dass die Auftragspositionen per Schleife durchlaufen werden müssen, um dann an den richtigen Namen zu kommen.
 

und-aus

Aktives Mitglied
5. April 2019
38
4
bei uns läuft genauso ein Workflow!
Wenn Bestand gleich 6, dann email an lieferanten mit Preisanfrage zu diesem Artikel.

Bei mir ist der Workflow unter >>Artikel >> Geändert einsortiert.
 

jtldudel

Sehr aktives Mitglied
4. Januar 2018
268
83
D.h. eine Bestandsänderung durch ausliefern löst einen Workflow unter Artikel Geändert aus? Interessant, wusste ich gar nicht. Das würde ja das Problem lösen!
 

Verkäuferlein

Sehr aktives Mitglied
29. April 2012
1.159
316
D.h. eine Bestandsänderung durch ausliefern löst einen Workflow unter Artikel Geändert aus? Interessant, wusste ich gar nicht. Das würde ja das Problem lösen!

Hm, das würde ich jetzt bezweifeln. Als ich das mal getestet habe, ging es nicht. Vermutlich wird der Workflow anderweitig getriggert. Z. B. durch einen täglichen Bestandsdaten-Import des Lieferanten oder ähnliches.

Das würde mich auch interessieren. Könnte das jemand bitte nochmal beantworten?

Danke!

Kannst Du doch ggf. selber einmal ausprobieren, wenn Du einen entsprechenden Workflow hast.

Meines Erachtens müssen erst diese Tickets hier angegangen werden, damit es wirklich sauber funktioniert:
https://issues.jtl-software.de/issues/WAWI-10099
https://issues.jtl-software.de/issues/WAWI-51411
https://issues.jtl-software.de/issues/WAWI-24438
 

grosskranfan

Neues Mitglied
18. Mai 2022
9
0
Es bedarf zwei Workflows, um alles abzudecken.
Unter Minusbuchung UND unter Auftrag ausgeliefert.
Hintergrund ist, dass nunmal das die Auslöser für die jeweiligen Workflows sind.
Eine Minusbuchung ist kein Ausgelieferter Auftrag und umgekehrt. Und ein erstellter Artikel - nun ja - der wird nur ein mal erstellt und danach nie wieder. Insofern kann so ein Workflow auch nur ein einziges mal pro Artikel ausgelöst werden.
Vielleicht denke ich zu naiv, aber was ist mit "Artikel->Geändert"?
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Funktionsattribut cms_page.name für Artikel funktioniert nicht Shopware-Connector 2
Neu 1.6.38.1 Zahlungsabgleich Import funktioniert nicht mehr JTL-Wawi - Fehler und Bugs 0
In Diskussion Nach Updates funktioniert Datenabgleich WaWi/POS nicht mehr Einrichtung / Updates von JTL-POS 3
Neu Lieferzeitanzeige Versandart DHL funktioniert nicht Betrieb / Pflege von JTL-Shop 1
Neu Komplettabgleich funktioniert nur teilweise Einrichtung JTL-Shop5 0
Neu Wann funktioniert der Shopware6 Connector? Shopware-Connector 8
Neu Paypal Checkout funktioniert nicht - Paypal Zahlungsart nicht mehr vorhanden Plugins für JTL-Shop 5
Neu Sortierung der Artikel nach Erscheinungsdatum funktioniert nicht korrekt Allgemeine Fragen zu JTL-Shop 1
In Bearbeitung E-Mail Versand funktioniert nicht mehr. JTL-POS - Fehler und Bugs 1
Neu Amazon Abgleich funktioniert nicht Amazon-Anbindung - Fehler und Bugs 5
Beantwortet Auftrag erstellt - Abfrage ob Eigenes Feld nicht leer funktioniert nicht JTL-Workflows - Fehler und Bugs 7
OnPage-Composer - Neuen entwurf erstellen funktioniert nicht wie gewollt Upgrade JTL-Shop4 auf JTL-Shop5 4
Neu Kontextmenu exportieren funktioniert nicht. JTL-Wawi - Fehler und Bugs 0
Gelöst Wenn der E-Mail Versand aus der POS mit web.de nicht funktioniert ( javax.mail.AuthenticationFailedException ) Einrichtung / Updates von JTL-POS 1
Neu Datenbankabfrage ob Lieferant Dropshipper funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 0
Neu [WaWi 1.6.35.1] Spalteneditor in Kundenübersicht funktioniert nicht richtig JTL-Wawi - Fehler und Bugs 0
Neu Artikelsuche funktioniert nur in deutschem Shop Allgemeine Fragen zu JTL-Shop 1
In Bearbeitung TSE-Einrichtung mit Epson TM-m30F via USB funktioniert nicht JTL-POS - Fehler und Bugs 1
Neu VCS Lite funktioniert nicht seit Update auf 1.5.54.1 JTL-Wawi - Fehler und Bugs 0
Verwiesen an Support WMS 1.6 GS1-128 EAN-128 Übertragung des FNC1 Befehls funktioniert nicht sauber JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 5
Neu Artikel Beschreibung: HTML Editor, CSS Datei einbinden funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 2
Neu JTL-Shop 5 - NEWS-Seite funktioniert nicht! Allgemeine Fragen zu JTL-Shop 4
Neu Amazon Anbindung funktioniert nicht richtig Amazon-Anbindung - Fehler und Bugs 6
Neu "Nur leitcodierte Sendungen zulassen" funktioniert nicht zuverlässig bei DHL JTL-ShippingLabels - Fehler und Bugs 1
Neu JTL Shop 5 SMTP- Anbindung funktioniert nicht JTL-Shop - Fehler und Bugs 6
Neu Retouren > nur angemeldete anzeigen im WMS Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 0
Neu Bei Zahlungsarten werden nur Vorkasse und Kreditkarte gezeigt JTL-Shop - Fehler und Bugs 1
Neu Mollie-Backend im 5er Shop lässt sich nur schwer aufrufen Plugins für JTL-Shop 1
Neu Element nur drucken wenn Seitenzahl > 1 ist Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu DATEV Anbindung nur direkt an den Steuerberater? Arbeitsabläufe in JTL-Wawi 0
Neu nur lieferschein errstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Exportvorlage - nur bestimmte Artikel im Feed - Fehlersuche Allgemeine Fragen zu JTL-Shop 4
Neu Komponenten-Namen nur auf deutsch im Auftrag, englischer Name wird nicht angezeigt JTL-Wawi - Fehler und Bugs 1
Neu Linke seitenleiste nur in mobileansicht ausblenden? Allgemeine Fragen zu JTL-Shop 2
Neu Nur Registrierte Kunden in die JTL-Wawi bei bestellugen Allgemeine Fragen zu JTL-Shop 0
Neu Auswahlassistenten mit Merkmalen nur zum Produkt Allgemeine Fragen zu JTL-Shop 0
Neu NOVA: Banner/Slider auf Startseite nur für registrierte User Templates für JTL-Shop 0
Neu Kategorie beim Aufruf immer anzeigen, auch wenn nur 1 Artikel enthalten ist Allgemeine Fragen zu JTL-Shop 2
Neu Artikelvariationen in Listenansicht nur mit hover @media 1300px sichtbar JTL-Shop - Fehler und Bugs 2
Neu Nur registrierte Benutzer sehen Artikel Allgemeine Fragen zu JTL-Shop 1
Neu Atttributimport - Import für weitere Sprachen nur möglich wenn auch die deutschen Werte noch einmal importiert werden? JTL-Ameise - Fehler und Bugs 9
Neu Verkauf nur in Verbindung mit einem anderen Produkt User helfen Usern - Fragen zu JTL-Wawi 2
Neu Minimaler Bug im Dashboard. Gruppierung Zeitbereich wird nur im Dashboard nicht korrekt angezeigt JTL-Wawi - Fehler und Bugs 0
Neu WAWI 1.6.36.0, Import von Lieferantenpreisen ergibt immer nur 1,- EUR JTL-Ameise - Fehler und Bugs 1
Neu Connectoreinstellungen um nur Versandstatus an Gambio-Shop zu übertragen Gambio-Connector 3
Neu Whatsapp installieren ohne Kontaktzugriff / nur eingeschränke Sichtbarkeit Smalltalk 5
Neu Ameise Export Rechnungen (neu) Export nur ein Datensatz für Rechnung mit zwei Steuersätzen? User helfen Usern - Fragen zu JTL-Wawi 14
Neu Amazon nur Aufträge abrufen, aber keine Produktdaten aktualisieren Amazon-Anbindung - Ideen, Lob und Kritik 6
Neu Wawi 1.45.1 - lastPage bei Mehrfachdruck nur 1 x drucken - wo liegt mein Fehler? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Artikelübersicht - Filter wird nur Mobil angezeigt JTL-Search 4

Ähnliche Themen