Änderungen am EVO-Template für eBay-Angebote

Michael Spaltmann

Moderator
Mitarbeiter
2. November 2010
490
70
Hi,

ab Juli deaktiviert eBay die Nutzung aktiver Inhalte wie JavaScript, Adobe Flash, Plugins und sendbare Formulare innerhalb von Angeboten. Dies beeinträchtigt die Funktionalität des von uns verwendeten EVO-Templates. Unsere Entwickler haben für Händler, die Produkte mittels EVO-Template auf eBay verkaufen, einen Workaround geschaffen, der sich mit wenig Aufwand nutzen lässt. Die Änderungen umfassen die folgenden 3 Schritte:

1. Shop-Suche entfernen
- Globale Texte Verwaltung öffnen

01-Globale-Texte.jpg

- Gruppe eBay- Designvorlagen
- Textbaustein "Shop-Suche" löschen

02-Shop-Suche-löschen.jpg

2. Artikelbilder-Galerie anpassen
- Globale Texte Verwaltung öffnen
- Gruppe eBay-Designvorlagen
- Wert des Textbausteins "Artikelbilder" durch diesen ersetzen:

Code:
        {% assign existiertZweitesBild = Vorgang.Bilder.Dateiname.Bild | ExistiertBild: 2 -%}
        <div class="text-center tab-menu" id="image_wrapper">
            <div class="pgwSlider listOnTheLeft narrow">                    
                <div class="ps-current">
                    <input type="radio" class="product-slider" checked="checked" name="image-slider" id="img-tab-1">
                    <div class="panel">
                     <img src="{{ Vorgang.Bilder.Dateiname.Bild01 | Groesse: 360,360}}" align="top" id="top_img" style="width:100%; max-width: 360px;"/>
                    </div>
                    {% if existiertZweitesBild -%}
                        {% for i in (2..12) %}
                            {% assign existiertBild = Vorgang.Bilder.Dateiname.Bild | ExistiertBild: i -%}
                            {% if existiertBild -%}
                                <input type="radio" class="product-slider" 1 name="image-slider" id="img-tab-{{ i }}">
                                <div class="panel">
                                 <img src="{{ Vorgang.Bilder.Dateiname.Bild | Bild: i | Groesse: 360,360}}" align="top" id="top_img"  style="width:100%; max-width: 360px;"/>
                                </div>
                            {% endif -%}
                        {% endfor -%}
                    {% endif -%}
                </div>
                {% if existiertZweitesBild -%}
                    <ul class="ps-list clearfix nav nav-tabs">
                    <li class="col-lg-2 col-md-2 col-xs-4">
                    <center>
                        {% for i in (1..12) %}
                            {% assign existiertBild = Vorgang.Bilder.Dateiname.Bild | ExistiertBild: i -%}
                            {% if existiertBild -%}
                                <a><label for="img-tab-{{i}}" style="background-color: white; padding: 27px;"><img class="gallery_img" src="{{ Vorgang.Bilder.Dateiname.Bild | Bild: i | Groesse: 75, 75 }}" border="0" width="100%"></label></a>
                            {% endif -%}
                        {% endfor -%}
                    </center>
                    </li>
                    </ul>
                {% endif -%}        
            </div>
        </div>

03-Artikelbilder-Code-anpassen.jpg


3. Mobile Darstellung verbessern
- Designvorlagen öffnen

04-Designvorlagen-öffnen.jpg

- EVO-Designvorlage (bzw. die angepasste Kopie) auswählen
- Tab "Bearbeiten"
- nach <head> (ca. Zeile 393) folgende Zeilen hinzufügen:


HTML:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
        <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">

05-Designvorlage-anpassen.jpg

Hinweis: Diese Anpassungen sind nur notwendig für EVO-Templates bis zur Version 1.2.2. Ab Version 1.2.3 neu erstellte EVO-Templates werden schon angepasst sein.

Grüße Michael
 
  • Gefällt mir
Reaktionen: msimpex.de und Pocket

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.937
313
Vielen Dank.

Was ist denn mit Bilder ALT-Tag? Wollten dies so lösen (Version 1.0.11.8):
Code:
alt="{{ Vorgang.Artikel.Beschreibung.Artikelname | SelectLanguage: Sprache }}"

Fehlermeldung:
Code:
alt="Liquid error: Das Objekt mit dem Typ "jtlDatabase.Templates.Drops.MehrsprachigDropifier" kann nicht in den Typ "jtlDatabase.classes.AttributeMaps.AusgabeTexteMehrsprachigMap" konvertiert werden."


Oder sollten wir für jede Sprache so umsetzen:
DEUTSCH
Code:
alt="{{ Vorgang.Artikel.Beschreibung.Artikelname.Deutsch }}"
ENGLISCH
Code:
alt="{{ Vorgang.Artikel.Beschreibung.Artikelname.Englisch }}"


Wäre halt etwas umständlich ...
 

gjennessen

Moderator
Mitarbeiter
14. August 2013
67
7
Hallo,

also im Grunde ist das richtig. Es sieht da so aus, als wäre die Variable "Sprache" nicht gesetzt. So sollte das funktionieren:

{% assign Sprache = Vorgang.Sprache -%}

{{ Vorgang.Artikel.Beschreibung.Artikelname | SelectLanguage: Sprache }}
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.937
313
In der Designvorlage selbst, ist dies bereits implementiert:
Code:
{% assign Sprache = Vorgang.Sprache -%}

Der Baustein für Bilder wird allerdings unter "Globale Texte Verwaltung" verwaltet!
Muss ich in dieser Verwaltung nochmals zusätzlich die Sprache assignen??? Ich denke nicht ...

Testet dies doch mal bitte :)
 

tanjana

Aktives Mitglied
29. November 2016
8
2
Irgendwie funtioniert das bei mir auch nach den Änderungen immer noch nicht so richtig...
mit dem i-ways Tester von ebay kommen folgende Meldungen immer noch:

JavaScript
Javascript im Quellcode vorhanden ▾
onload wurde gefunden.
Die Nutzung von Javascript wird von eBay ab 2017 blockiert. Bitte vergewissen Sie sich, dass Sie kein Javascript in Ihren eBay Angeboten verwenden. Meistens wird Javascript für die Darstellung von Gallerien, Cross-Selling, Kaufen Buttons oder visuelle Effekte verwendet.
HTML Links
Template verwendet HTML Links ▾
<a href="http://bilder2.eazyauction.de/plumps68/templates/7083_20532_0f1d37c9/tanjanashop"> wurde gefunden.
HTML 5 Standards erlauben nur eingeschränkte Nutzung von HTML Links im Sandbox Modus. Es ist noch nicht klar, in welchem Umfang wird die Nutzung von Links in eBay Angebote erlaubt. Wir werden die Analyse entsprechend anpassen, wenn für dieses Punkt eine deutliche Stellung von eBay vorliegt.
und:

Target Blank Links
Links ohne das Attribut target=“_blank“ gefunden. ▾
Stellen Sie bitte sicher, dass alle Links in Ihrer Artikelbeschreibung das Attribut target=“_blank“ beinhalten, da diese sonst nicht mehr einwandfrei funktionieren.
Beispiel: <a href="http://www.ebay.de" target="_blank">eBay</a>.

Da meckert es immer noch :S
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.356
769
Das hat aber bei dir - vermutlich - nichts mit dem Template zu tun, sondern mit deiner Artikelbeschreibung.

Du hast bei der geprüften Auktion einen Link in deiner Beschreibung.
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.356
769
2 und 3 haben ja auch miteinander zu tun und 1 ist halt ein javascript im template/artikelbeschreibung, steht ja auch in der Erklärung dabei ( cross-selling, video etc).
 

kleinerkobold

Aktives Mitglied
27. Dezember 2012
69
3
Haben wir umgesetzt - soweit ok, was die aktiven Inhalte betrifft. Jetzt weist iways einen Fehler bei der Inhaltsbreite aus "Inhaltsbreite
Die Inhaltsbreite ist größer als die Viewport-Breite ▾
Viewport-Breite: 320 px, Inhaltsbreite: 333 px" Wo könnte hier noch der Fehler liegen und wie kann der gelöst werden?
 

whd-online

Aktives Mitglied
21. Dezember 2009
93
2
Schwarmstedt
Moin,
bei mir zeigt der i-ways Tester
Target Blank Links
Links ohne das Attribut target=“_blank“ gefunden.

Leider finde ich dazu keinen Link in der Artikelbeschreibung.
EBay Beispiel Nummer: 261544827252
Template Neapel von NMB-Media

Da Ebay wohl ab Juni 2017 Angebote mit fehlenden Target _blank nicht mehr zeigt,
wäre ich über Hilfe dankbar.
:)

Gruß
Wolfgang Weber
Handel und Dienstleistung
 

nmueller

Sehr aktives Mitglied
5. April 2011
1.282
87
Saarland
Moin,
bei mir zeigt der i-ways Tester
Target Blank Links
Links ohne das Attribut target=“_blank“ gefunden.

Leider finde ich dazu keinen Link in der Artikelbeschreibung.
EBay Beispiel Nummer: 261544827252
Template Neapel von NMB-Media

Da Ebay wohl ab Juni 2017 Angebote mit fehlenden Target _blank nicht mehr zeigt,
wäre ich über Hilfe dankbar.
:)

Gruß
Wolfgang Weber
Handel und Dienstleistung

Designverwaltung in der Wawi öffnen
auf bearbeiten gehen
STRG-F drücken
eingeben: <a href
suchen lassen
jeden gefundenen Link um target="_blank" ergänzen oder target="_top" ersetzen.

Alternativ: Update runter laden. https://www.nmb-media.de/download-center/kostenlose-eazyauction-templates/file/144-neapel-ea-1-0

Betrifft:
Logo (Link führt zum ebayshop)
Navigation
Kategorien
Cross-Selling
Copyright in Fußzeile

Betrifft nicht:
Produktbildgalerie
verlinkte Mailadressen <a href="mailto...
 

La-Ra

Aktives Mitglied
27. Juni 2016
28
2
Hallo zusammen,

vielen Dank für die ausführlichen Erklärungen! Ich habe jetzt alle findbaren Links um target="_blank" erweitert, die Fehlermeldung von i-ways bleibt allerdings die gleiche, "Links ohne das Attribut target=“_blank“ gefunden."... Hat vielleicht noch jemand einen Tip, ein Beispiel-Angebot ist die Nummer 391747367990

Danke vielmals!
 

gjennessen

Moderator
Mitarbeiter
14. August 2013
67
7
In der Designvorlage selbst, ist dies bereits implementiert:
Code:
{% assign Sprache = Vorgang.Sprache -%}

Der Baustein für Bilder wird allerdings unter "Globale Texte Verwaltung" verwaltet!
Muss ich in dieser Verwaltung nochmals zusätzlich die Sprache assignen??? Ich denke nicht ...

Testet dies doch mal bitte :)

Wenn man eine dotLiquid Script in einem globalen Text hat, ist dieser vom Rest gekapselt und kann nicht auf die Variablen zugreifen, welche in der Designvorlage mit {% assign .. -%} definiert wurden. Daher muss innerhalb eines Bausteins dieser Variable neu zugewiesen werden.
 
  • Gefällt mir
Reaktionen: wawi-dl

gjennessen

Moderator
Mitarbeiter
14. August 2013
67
7
Das Problem mit dem fehlenden Attribut target="_blank" bei den Cross-Selling Galerien ist, dass diese von der Wawi generiert werden. Daher kann man nicht direkt in der Designvorlage dieses Attribut hinzufügen. Man kann sich aber mit dotLiquid da behelfen.
Ungefähr bei Zeile 509 wir die Galerie mit
Code:
{{ GalerieContainer | CreateHtmlGallery }}

erzeugt.
Hier kann man mit dem dotLiquid Filter "Replace" die enthaltenen Links anpassen. Dazu einfach die Zeile durch diesen Code ersetzen:
Code:
{% assign htmlGallery = GalerieContainer | CreateHtmlGallery  -%}
{% assign htmlGallery = htmlGallery | Replace : 'class="image-wrapper"','class="image-wrapper" target="_blank"' -%}
{% assign htmlGallery = htmlGallery | Replace : 'class="title"','class="title" target="_blank"' -%}
{{ htmlGallery}}
 
  • Gefällt mir
Reaktionen: wawi-dl

La-Ra

Aktives Mitglied
27. Juni 2016
28
2
Also bei uns ändert sich nichts, immer wieder die gleichen Fehlermeldungen bei i-ways... Mittlerweile sitz ich seit 3 Tagen dran, ohne Erfolg!

Liebes JTL-Team, ich weiß, ihr habt viel um die Ohren und ihr macht aus meiner Sicht auch einen wirklich guten Job, aber die Anpassungen beim zu verwendenden EVO-Design dem Kunden zu überlassen halte ich für "schwierig". Ich werde die Sache jetzt hier abbrechen und mich wohl oder übel um ein fremdes Template bemühen, Aufwand und Nutzen der Anpassung stehen hier in keinem Verhältnis mehr zueinander! Schade!
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.937
313
Das Problem liegt aber auch an i-ways selbst, man sollte hierzu auch mal eBay befragen ;)
Wir meinen auch alle entfernt zu haben, dennoch erhalten wir die Fehler.
 

gjennessen

Moderator
Mitarbeiter
14. August 2013
67
7
Ich hab jetzt auch noch mal alles versucht was geht und bei i-ways ein Angebot getestet, welches definitiv keine Links ohne das Attribut "target="_blank" hat und es kommt immer noch der Hinweis: "Links ohne das Attribut target=“_blank“ gefunden."
Jetzt kann nur noch eBay sagen was da los ist.
 
  • Gefällt mir
Reaktionen: La-Ra und wawi-dl

La-Ra

Aktives Mitglied
27. Juni 2016
28
2
Ich hab jetzt auch noch mal alles versucht was geht und bei i-ways ein Angebot getestet, welches definitiv keine Links ohne das Attribut "target="_blank" hat und es kommt immer noch der Hinweis: "Links ohne das Attribut target=“_blank“ gefunden."
Jetzt kann nur noch eBay sagen was da los ist.
Vielen Dank dafür, dann liegt es vielleicht tatsächlich (mal wieder) an ebay bzw. i-ways... Danke!
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Eigene Felder, Änderungen in Werteliste werden nicht übernommen JTL-Wawi - Fehler und Bugs 1
In Bearbeitung Änderungen an Pfandartikeln werden nicht übernommen JTL-POS - Fehler und Bugs 1
Neu Wie bekomme ich Änderungen im Childtheme mehrsprachig? Templates für JTL-Shop 2
Neu Änderungen werden nicht übertragen Allgemeine Fragen zu JTL-Shop 0
Neu Shop 5.1.1 und Evo-Template 5.1.0: Fehlerhafte Bildergalerie- und Preisaktualisierung bei Variationen in Artikel-Übersicht und Artikel-Detailseite JTL-Shop - Fehler und Bugs 0
Weiße Seite beim NOVA-Template, EVO geht Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Header Box im Shop 5 Nova / Evo.. Templates für JTL-Shop 3
Neu Ebay Angebotsaktualisierung Evo Template bei neuem Artikelbild? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Filter mit nur einem Merkmalwert ausblenden Shop 5 EVO Technische Fragen zu Plugins und Templates 0
Neu Ansicht JTL Search unter Shop 5-Evo JTL-Search 0
Neu Ist eine Bildvergößerung im NOVA-Template möglich wie im EVO-Template Technische Fragen zu Plugins und Templates 0
Neu Evo Designvorlage Farben / Elemente eBay-Designvorlagen - Ideen, Lob und Kritik 1
Neu JTL 5 Shop -> Slick Slider auf der Startseite im Nova Template verändern Templates für JTL-Shop 2
Neu Template Anpassung im Child Theme via JTL Theme Editor -> my-nova.scss Templates für JTL-Shop 0
Neu NOVA Template Farbänderung in verschiedenen Bereichen Templates für JTL-Shop 5
Neu JTL SHOP 5.0.1 / NOVA-Template UVP/Rabattanzeige Artikelübersichten Allgemeine Fragen zu JTL-Shop 5
Neu JTL5.1.1 Nova-Template mit Child Mobiles Menü Templates für JTL-Shop 6
Neu Template Nova/layout/header_nav_search.tpl <li>? JTL-Shop - Fehler und Bugs 3
Neu Kritisch: JTL Shop 5.1 Bugs: Template: blackline, Demo-Dateien, Composer und co. JTL-Shop - Fehler und Bugs 22
Neu NOVA Template linke Navigation? Templates für JTL-Shop 2
Neu Animations Balken im Nova Template Farbe ändern Templates für JTL-Shop 2
Neu Mod Pagespeed webp konvertiung zerschiesst template Technische Fragen zu Plugins und Templates 0
Neu NOVA Template lässt sich nicht aktivieren JTL-Shop - Fehler und Bugs 4
Neu Shop 5 NOVA Template - Menü ohne Kategorien Allgemeine Fragen zu JTL-Shop 4
Neu Bug: Template Datein des Child-Templates werden nicht bei include anweisungen geladen JTL-Shop - Fehler und Bugs 2
Fragen zum Update von 4 zu 5 - Template Migration Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Template Anpassung UVP größer als VK Templates für JTL-Shop 1
Neu header.tpl wird nicht aus dem Child Template genommen JTL-Shop - Fehler und Bugs 5
Neu EU Energielabel Nova Template Templates für JTL-Shop 2
Neu NOVA Template - Megamenu Oberkategorie Link entfernen Templates für JTL-Shop 2
Neu NOVA Template - dunkler Hintergrund bei ausklappendem Megamenu Templates für JTL-Shop 4
Neu NOVA Template Preisspannen Slider noUI-touch-area sekundäre Farbe ändern Templates für JTL-Shop 2
Neu Brauche Hilfe bei einem Template - nicht alle if-Anweisungen funktionieren Dienstleistung, Jobs und Ähnliches 0
Komprimierung des HTML-Ausgabedokuments / Template Einstellung fehlt JTL Shop5 ? Einrichtung JTL-Shop5 0
Neu NOVA Template JTL Shop 5 eigenen Content-Block zwischen Footer und Produktdetailsseiten Technische Fragen zu Plugins und Templates 2
Neu Schriftgröße des Menüs im Nova Child Template vergrößern Templates für JTL-Shop 2
JTL Shop 5 Nova Template out of the box nicht responsiv? Einrichtung JTL-Shop5 2
Neu Template einzelnen Lagerstand anzeigen Templates für JTL-Shop 2
Neu Template Nova: Grauen Schatten Linie in anderer Farbe Templates für JTL-Shop 2
Neu Missing currency in "Zahlungseingang" mail template (English) JTL-Wawi - Fehler und Bugs 0
Neu Textfarbe "Neu hier? Jetzt registrieren!" in NOVA Template ändern Templates für JTL-Shop 2
Neu Nova-Template Menü anpassen Templates für JTL-Shop 0

Ähnliche Themen